summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-08 08:09:40 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-08 08:09:40 +1200
commitd97bd90df8d8d6f23b4c25a5719b905472429756 (patch)
tree281b03b13dec23a9d1c121a6d70184c3d46a3b7c /dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild
parentdev-perl/Math-FFT: Bump to version 1.340.0 (diff)
downloadgentoo-d97bd90df8d8d6f23b4c25a5719b905472429756.tar.gz
gentoo-d97bd90df8d8d6f23b4c25a5719b905472429756.tar.bz2
gentoo-d97bd90df8d8d6f23b4c25a5719b905472429756.zip
dev-perl/Bio-ASN1-EntrezGene: Bump to 1.720.0
Upstream: - Fix for unescaped left brace in regex Bug: https://bugs.gentoo.org/614938 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild')
-rw-r--r--dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild b/dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild
new file mode 100644
index 000000000000..c2c545b2ecbb
--- /dev/null
+++ b/dev-perl/Bio-ASN1-EntrezGene/Bio-ASN1-EntrezGene-1.720.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CJFIELDS
+DIST_VERSION=1.72
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Regular expression-based Perl Parser for NCBI Entrez Gene"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-parent
+ >=sci-biology/bioperl-1.6.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/release-*.t
+ perl-module_src_test
+}