summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-10 03:33:53 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-10 03:35:01 +1200
commit59a04a481c15788a6798996b271efabbbcc78a03 (patch)
treeb56930c91c71635bed84d3aa0436596a4b888e6c /dev-perl/Boulder/Boulder-1.300.0-r2.ebuild
parentRevert "app-emulation/qemu: conditionally depend on python" (diff)
downloadgentoo-59a04a481c15788a6798996b271efabbbcc78a03.tar.gz
gentoo-59a04a481c15788a6798996b271efabbbcc78a03.tar.bz2
gentoo-59a04a481c15788a6798996b271efabbbcc78a03.zip
dev-perl/Boulder: Bulk fixes and fix for bug #678004
- Convert to EAPI6 - Omit Boulder::Store support unless USE=store is specified, as Boulder::Store requires DB_File, which requires perl built with USE="berkdb", and triggering a perl rebuild flipping a use flag could really complicate portage's capacity to solve dependencies, and possibly break your perl. (This is exposed bug bug #678004) - Omit Boulder::Labbase as the module is incomplete, is documented as such, and loads dependencies that aren't available on Gentoo or on CPAN. - Omit Boulder::XML and its dependency on XML-Parser unless USE=xml is specified, as XML handling is not in any way critical to this module. - Remove uncondtional compile-time assertion for XML::Parser - Omit Boulder::Genbank and related assets unless USE=genbank is specified, as this necesarily adds a dependency on dev-perl/CGI as part of its Entrez accessor - Provide examples via USE="examples" Closes: https://bugs.gentoo.org/678004 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Boulder/Boulder-1.300.0-r2.ebuild')
-rw-r--r--dev-perl/Boulder/Boulder-1.300.0-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Boulder/Boulder-1.300.0-r2.ebuild b/dev-perl/Boulder/Boulder-1.300.0-r2.ebuild
new file mode 100644
index 000000000000..a9c75068e9ba
--- /dev/null
+++ b/dev-perl/Boulder/Boulder-1.300.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=1.30
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="An API for hierarchical tag/value structures"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="genbank store xml"
+
+RDEPEND="
+ genbank? ( dev-perl/CGI )
+ store? ( virtual/perl-DB_File )
+ xml? ( dev-perl/XML-Parser )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-xml-parser-check.patch"
+)
+PERL_RM_FILES=(
+ # Incomplete, instructs not to use, deps not in Gentoo
+ "Boulder/Labbase.pm"
+)
+src_prepare() {
+ use xml || PERL_RM_FILES+=(
+ "Boulder/XML.pm"
+ )
+ use genbank || PERL_RM_FILES+=(
+ "Boulder/Genbank.pm"
+ "Stone/GB_Sequence.pm"
+ "doc/genbank_tags.txt"
+ "eg/gb_get"
+ "eg/gb_search"
+ "eg/genbank.pl"
+ "eg/genbank2.pl"
+ "eg/genbank3.pl"
+ )
+ use store || PERL_RM_FILES+=(
+ "Boulder/Store.pm"
+ "t/store.t"
+ )
+ perl-module_src_prepare
+}