summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-30 01:24:08 +0100
committerSam James <sam@gentoo.org>2024-04-30 01:24:08 +0100
commitce7f7ba787840f453b900bde4fa0d62dfa7ca2c5 (patch)
tree6dae15dfe77165ff34d29efb42b8cbe60261aedf /dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild
parentdev-qt/qtwebengine: fix build w/ ninja-1.12 for qt5 (diff)
downloadgentoo-ce7f7ba787840f453b900bde4fa0d62dfa7ca2c5.tar.gz
gentoo-ce7f7ba787840f453b900bde4fa0d62dfa7ca2c5.tar.bz2
gentoo-ce7f7ba787840f453b900bde4fa0d62dfa7ca2c5.zip
dev-perl/Business-ISBN: add 3.9.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild')
-rw-r--r--dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild b/dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild
new file mode 100644
index 000000000000..ff70a0c929ed
--- /dev/null
+++ b/dev-perl/Business-ISBN/Business-ISBN-3.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BRIANDFOY
+DIST_VERSION=3.009
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Work with ISBN as objects"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+IUSE="test barcode"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ barcode? (
+ dev-perl/GD-Barcode
+ dev-perl/GD[png(+)]
+ )
+ >=dev-perl/Business-ISBN-Data-20230322.1.0
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=virtual/perl-Test-Simple-1
+ )
+"
+
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod_coverage.t"
+)
+
+src_prepare() {
+ sed -i -e '/^pod\.t/d;/^pod_coverage\.t/d' t/test_manifest || die "Can't fix test_manifest"
+ perl-module_src_prepare
+}