summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-09-30 17:37:55 +1300
committerKent Fredric <kentnl@gentoo.org>2018-09-30 17:38:13 +1300
commitf2cfc274eea290c90fd74deec2d59cac636c3a5e (patch)
treeceaffdd5023fd3c70df1c69833df6a0bd64bf207 /dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild
parentmedia-sound/music-file-organizer: version bump (diff)
downloadgentoo-f2cfc274eea290c90fd74deec2d59cac636c3a5e.tar.gz
gentoo-f2cfc274eea290c90fd74deec2d59cac636c3a5e.tar.bz2
gentoo-f2cfc274eea290c90fd74deec2d59cac636c3a5e.zip
dev-perl/Business-ISSN: Bump to version 1.3.0
- Use declarative syntax for pruning unwanted files - Patch out Test::Manifest stuff - Remove redundant nuking of /usr/share/man Upstream: - Clarify license as Artistic-2 Signed-off-by: Kent Fredric <kentnl@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild')
-rw-r--r--dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild b/dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild
new file mode 100644
index 000000000000..059442952248
--- /dev/null
+++ b/dev-perl/Business-ISSN/Business-ISSN-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.003
+inherit perl-module
+
+DESCRIPTION="Object and functions to work with International Standard Serial Numbers"
+LICENSE="Artistic-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod_coverage.t"
+ "t/test_manifest"
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.003-no-test-manifest.patch"
+)