summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-22 08:18:18 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-22 08:28:38 +1200
commit89c722cafb7b7cf9a83c34774bb04f20371b8f2c (patch)
tree5742d5f9e7d0ecc278206327f6c728ef2bbb2e7d /dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild
parentdev-perl/Math-Random-ISAAC-XS: -r bump for EAPI7 + Toolchain love (diff)
downloadgentoo-89c722cafb7b7cf9a83c34774bb04f20371b8f2c.tar.gz
gentoo-89c722cafb7b7cf9a83c34774bb04f20371b8f2c.tar.bz2
gentoo-89c722cafb7b7cf9a83c34774bb04f20371b8f2c.zip
dev-perl/Bytes-Random-Secure: Add w/ version=0.290.0
Required optionally by dev-perl/Crypt-PWSafe3 And Crypt-PWSafe3 requested by juippis as an optional dependency of app-admin/kpcli Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild')
-rw-r--r--dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild b/dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild
new file mode 100644
index 000000000000..8eb310b499e8
--- /dev/null
+++ b/dev-perl/Bytes-Random-Secure/Bytes-Random-Secure-0.290.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAVIDO
+DIST_VERSION=0.29
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="extension to generate cryptographically-secure random bytes"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Crypt-Random-Seed
+ virtual/perl-Exporter
+ >=virtual/perl-MIME-Base64-3.30.0
+ dev-perl/Math-Random-ISAAC
+ >=virtual/perl-Scalar-List-Utils-1.210.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.560.0
+ test? (
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Test-Simple-0.980.0
+ virtual/perl-Time-HiRes
+ !minimal? (
+ dev-perl/Statistics-Basic
+ )
+ )
+"
+PERL_RM_FILES=(
+ t/00-boilerplate.t
+ t/01-manifest.t
+ t/02-pod.t
+ t/03-pod-coverage.t
+ t/04-perlcritic.t
+ t/05-kwalitee.t
+ t/06-meta-yaml.t
+ t/07-meta-json.t
+ t/09-changes.t
+)