summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-19 13:22:18 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-19 13:22:18 +1200
commit821395055e48714f6ed2986ebe8b3d9b9f323ab9 (patch)
treeceb508d0e4506aef92a8ef2abb398d52223c029b /dev-perl/CDB_File/CDB_File-0.990.0.ebuild
parentdev-perl/Carp-Clan: Bump to version 6.60.0 (diff)
downloadgentoo-821395055e48714f6ed2986ebe8b3d9b9f323ab9.tar.gz
gentoo-821395055e48714f6ed2986ebe8b3d9b9f323ab9.tar.bz2
gentoo-821395055e48714f6ed2986ebe8b3d9b9f323ab9.zip
dev-perl/CDB_File: Bump to version 0.990.0
- EAP6 - bun-x.pl now only installed as an example when under USE=examples Upstream: - Add "fetch_all" method on object to return a copy of the database as a hash, which is faster for iterating than a tied hash. Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/CDB_File/CDB_File-0.990.0.ebuild')
-rw-r--r--dev-perl/CDB_File/CDB_File-0.990.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/CDB_File/CDB_File-0.990.0.ebuild b/dev-perl/CDB_File/CDB_File-0.990.0.ebuild
new file mode 100644
index 000000000000..c38cc4809ba8
--- /dev/null
+++ b/dev-perl/CDB_File/CDB_File-0.990.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.99
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Tie to CDB (Bernstein's constant DB) files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_prepare() {
+ mkdir "${S}/examples"
+ einfo "Moving bun-x.pl to examples/"
+ cp "${S}/bun-x.pl" "${S}/examples/"
+ perl_rm_files bun-x.pl
+ perl-module_src_prepare
+}