summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-20 14:20:34 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-20 14:20:57 +1300
commitbaf43f791bc25cb2e1dfbf8326546ade4fb44959 (patch)
tree4c9acf47348e2a0de0307a2774eff1a44de36219 /dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild
parentmedia-libs/mesa: Wrap vulkan header removal with check (diff)
downloadgentoo-baf43f791bc25cb2e1dfbf8326546ade4fb44959.tar.gz
gentoo-baf43f791bc25cb2e1dfbf8326546ade4fb44959.tar.bz2
gentoo-baf43f791bc25cb2e1dfbf8326546ade4fb44959.zip
dev-perl/CGI-Fast: Bump to version 2.110.0
- EAPI6 - Disable bad author tests Upstream: - Actually use dependency CGI::Carp Keywords: - Dependency on dev-perl/FCGI has broken keywording - Dropped keywords: amd64-fbsd, arm64, m68k, mips, s390, sh, x86-fbsd Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild')
-rw-r--r--dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild b/dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild
new file mode 100644
index 000000000000..3efee549df63
--- /dev/null
+++ b/dev-perl/CGI-Fast/CGI-Fast-2.110.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=2.11
+inherit perl-module
+
+DESCRIPTION="CGI Interface for Fast CGI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/CGI-4
+ virtual/perl-Carp
+ >=dev-perl/FCGI-0.670.0
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/006_changes.t
+ perl-module_src_test
+}