summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-19 16:45:03 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-19 16:45:03 +1200
commit154cfea7d79f54499f4fad82441548a0ff7e9a27 (patch)
tree1ba21c764334bbda9a97ffc0b67c6a37de8ad816 /dev-perl/CGI/CGI-4.310.0.ebuild
parentdev-perl/CDB_File: Bump to version 0.990.0 (diff)
downloadgentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.tar.gz
gentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.tar.bz2
gentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.zip
dev-perl/CGI: Bump to version 4.310.0
- Add USE="examples" - Remove author tests - Update metadata.xml remote-id's Upstream: - HTML attributes now sorted by default - warnings fixed in test harness and STORE sub - taint addedf to file_upload example - %QUERY_PARAM now cleaned/unset under mod_perl - Cookie handling now supports SameSite - MultipartBuffer renamed to CGI::MultipartBuffer Keywording: ~amd64-fbsd: Dropped, not supported by dependency dev-perl/Test-Deep ~m68k: Dropped, not supported by dependency dev-perl/Test-Warn Package-Manager: portage-2.3.0 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/CGI/CGI-4.310.0.ebuild')
-rw-r--r--dev-perl/CGI/CGI-4.310.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.310.0.ebuild b/dev-perl/CGI/CGI-4.310.0.ebuild
new file mode 100644
index 000000000000..bc7909e533b8
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.310.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.31
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-File-Temp-0.170.0
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Deep-0.110.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+
+src_test() {
+ perl_rm_files t/compiles_pod.t t/changes.t
+ perl-module_src_test
+}