summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-14 03:01:33 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-14 03:10:01 +1200
commit2c58128ee88e4869b802230e341c0645cf1e07c0 (patch)
tree03687790c58061de288e34b4ce604ac9293f1d97 /dev-perl/Cairo
parentnet-misc/geoipupdate: bump with go-module conversion (diff)
downloadgentoo-2c58128ee88e4869b802230e341c0645cf1e07c0.tar.gz
gentoo-2c58128ee88e4869b802230e341c0645cf1e07c0.tar.bz2
gentoo-2c58128ee88e4869b802230e341c0645cf1e07c0.zip
dev-perl/Cairo: Bump to version 1.107.0
- EAPI7 - Add USE="examples" - Replace sed invocation with a patch - Enable parallel tests - I see no evidence of bug #663478 or bug #641494, which may be the same bug in differing presentations. Affected users are encouraged to reproduce and give information about their installed cairo and libpng's and applicable USE flags. Upstream: - Add bindings for cairo_tag_begin and cairo_tag_end - Add binding for cairo_pdf_surface_set_metadata Bug: https://bugs.gentoo.org/641494 Bug: https://bugs.gentoo.org/663478 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Cairo')
-rw-r--r--dev-perl/Cairo/Cairo-1.107.0.ebuild32
-rw-r--r--dev-perl/Cairo/Manifest1
-rw-r--r--dev-perl/Cairo/files/Cairo-1.107-fatal-exit.patch25
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.107.0.ebuild b/dev-perl/Cairo/Cairo-1.107.0.ebuild
new file mode 100644
index 000000000000..ca2d059a3492
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.107.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.107
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.107-fatal-exit.patch"
+)
diff --git a/dev-perl/Cairo/Manifest b/dev-perl/Cairo/Manifest
index dac3b87668c6..ae413017ffaf 100644
--- a/dev-perl/Cairo/Manifest
+++ b/dev-perl/Cairo/Manifest
@@ -1 +1,2 @@
DIST Cairo-1.106.tar.gz 108779 BLAKE2B 9658623bf83952066f2a3a4741130c41bb79ca95c57e9c32dd0e63bec2801610d3c3fea72b844edcff213ff864021188e15803cbc80e6065ef48a0c386af37d9 SHA512 190435f99e4c7a8f5e8d48834639b9e12c6bc4d5dfe721a2820de3479dd3f2144e1fc1ea74e7796fd7b219a45591b55c7648488e6dd276106bc5e51b0467fee7
+DIST Cairo-1.107.tar.gz 111203 BLAKE2B 17093ee7058ecf27848042d3f49a841b6d6b4be9327adb959ee0d93a10f03de9caecd172b31775847b3561470aaf0f3c72b458fe0b37d2a451df47833e0df622 SHA512 613ba59ee3bd1adc2f33be60b395148f23d1de793fde888fd417f0b0cb6631a35429ee696172e9292b7d3fecab93de8ca958c96f803b9f5a16747a6d1fc7e9cb
diff --git a/dev-perl/Cairo/files/Cairo-1.107-fatal-exit.patch b/dev-perl/Cairo/files/Cairo-1.107-fatal-exit.patch
new file mode 100644
index 000000000000..cc1274af4eb7
--- /dev/null
+++ b/dev-perl/Cairo/files/Cairo-1.107-fatal-exit.patch
@@ -0,0 +1,25 @@
+From 96dd5b512e7761626b6924df471bfec50983eeb7 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 14 May 2020 02:39:16 +1200
+Subject: Abort with a non-zero exit code
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index d7a6d49..8960261 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -99,7 +99,7 @@ my %cairo_cfg;
+ eval { %cairo_cfg = ExtUtils::PkgConfig->find ("cairo >= $extreqs{cairo}"); };
+ if ($@ ne '') {
+ warn $@;
+- exit 0;
++ exit 1;
+ }
+
+ my %objects = (
+--
+2.26.2
+