summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-19 00:12:04 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-19 00:12:30 +1200
commit32c6e7a84c48cc6aff8129fc0861aa5e0da8b047 (patch)
tree7b6654ce874aec0e86da454e284e17b2841d2fd9 /dev-perl/Class-Container/Class-Container-0.130.0.ebuild
parentsci-electronics/iverilog: optimize RDEPEND for 9999 (diff)
downloadgentoo-32c6e7a84c48cc6aff8129fc0861aa5e0da8b047.tar.gz
gentoo-32c6e7a84c48cc6aff8129fc0861aa5e0da8b047.tar.bz2
gentoo-32c6e7a84c48cc6aff8129fc0861aa5e0da8b047.zip
dev-perl/Class-Container: Bump to version 0.130.0
- EAPI7 - Strip author tests Upstream: - Fix failure for dot-in-inc in perl 5.26+ - Packaging overhaul Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Class-Container/Class-Container-0.130.0.ebuild')
-rw-r--r--dev-perl/Class-Container/Class-Container-0.130.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Class-Container/Class-Container-0.130.0.ebuild b/dev-perl/Class-Container/Class-Container-0.130.0.ebuild
new file mode 100644
index 000000000000..6ca9808b5759
--- /dev/null
+++ b/dev-perl/Class-Container/Class-Container-0.130.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Glue object frameworks together transparently"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Params-Validate-0.24-r1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ >=dev-perl/Module-Build-0.360.100
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test
+ )
+"
+PERL_RM_FILES=(
+ "t/author-critic.t"
+)