summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-12 22:08:55 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-12 22:08:55 +0200
commit4d9784879649691cbefc98d7d1ea358173687167 (patch)
tree897878ddf53ed971120d95ff555892851d39a789 /dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild
parentdev-perl/Graphics-ColorNames-HTML: New package, needed as dependency (diff)
downloadgentoo-4d9784879649691cbefc98d7d1ea358173687167.tar.gz
gentoo-4d9784879649691cbefc98d7d1ea358173687167.tar.bz2
gentoo-4d9784879649691cbefc98d7d1ea358173687167.zip
dev-perl/Color-Calc: EAPI=8 bump, add missing dependency
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild')
-rw-r--r--dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild b/dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild
new file mode 100644
index 000000000000..6e5cb94b1bf6
--- /dev/null
+++ b/dev-perl/Color-Calc/Color-Calc-1.74.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CFAERBER
+DIST_VERSION=1.074
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Simple calculations with RGB colors"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ >=dev-perl/Graphics-ColorNames-2.100.0
+ dev-perl/Graphics-ColorNames-HTML
+ >=dev-perl/Graphics-ColorNames-WWW-0.10.0
+ !minimal? ( >=dev-perl/Graphics-ColorObject-0.5.0 )
+ >=dev-perl/Params-Validate-0.750.0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-NoWarnings
+ )
+"
+
+PERL_RM_FILES=( t/10pod.t t/11pod_cover.t )