summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-22 06:44:46 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-22 06:50:41 +1200
commit46d76f54d6fbf257d0f1233fbbf30b0bf0b564a3 (patch)
tree8a9dbf07f765761a12b54684cc97131f9817ee03 /dev-perl/Convert-UUlib/files
parentdev-libs/qoauth: EAPI-7 bump (diff)
downloadgentoo-46d76f54d6fbf257d0f1233fbbf30b0bf0b564a3.tar.gz
gentoo-46d76f54d6fbf257d0f1233fbbf30b0bf0b564a3.tar.bz2
gentoo-46d76f54d6fbf257d0f1233fbbf30b0bf0b564a3.zip
dev-perl/Convert-UUlib: Bump to version 1.710.0
- EAPI7 - Drop USE="system-uulib" due to being completely broken and unfixable - Fix directly calling `ar` and inherit Perl's `ar` - Attempt to correct a dizzying array of license terms Upstream: - Fix heap overflow - Fix format string type missmatches - Simplify code in _FP_gets to not use fscanf for performance - Backport code to c89 - Add GetFileList - experimental perlmulticore support - Speedup yEnc encoding using slice-by-16 instead of crc32 Bug: https://bugs.gentoo.org/559930 Bug: https://bugs.gentoo.org/723216 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Convert-UUlib/files')
-rw-r--r--dev-perl/Convert-UUlib/files/Convert-UUlib-1.71-tc-ar.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Convert-UUlib/files/Convert-UUlib-1.71-tc-ar.patch b/dev-perl/Convert-UUlib/files/Convert-UUlib-1.71-tc-ar.patch
new file mode 100644
index 000000000000..fdce341d9824
--- /dev/null
+++ b/dev-perl/Convert-UUlib/files/Convert-UUlib-1.71-tc-ar.patch
@@ -0,0 +1,25 @@
+From 8a250730c8d73feea322f5a5beeaa16cbaa05d3a Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 22 May 2020 04:58:39 +1200
+Subject: Fix direct calling of ar
+
+---
+ uulib/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/uulib/Makefile.in b/uulib/Makefile.in
+index 06a820d..65bae91 100644
+--- a/uulib/Makefile.in
++++ b/uulib/Makefile.in
+@@ -69,7 +69,7 @@ new: clean
+
+ libuu.a: $(UULIB_OBJ)
+ rm -f $@
+- ar r $@ $(UULIB_OBJ)
++ $(AR) r $@ $(UULIB_OBJ)
+ -$(RANLIB) $@
+
+ .c.o:
+--
+2.26.2
+