summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-06 07:10:23 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 07:10:42 +1200
commit41023af807408d1a265c67eed2a5c15acb50dd0b (patch)
treee969aaca9746531df4a004f5796a9c2b478331a2 /dev-perl/Coro/Coro-6.550.0.ebuild
parentmedia-gfx/imagemagick: bump to v6.9.11-23 & v7.0.10-23 (diff)
downloadgentoo-41023af807408d1a265c67eed2a5c15acb50dd0b.tar.gz
gentoo-41023af807408d1a265c67eed2a5c15acb50dd0b.tar.bz2
gentoo-41023af807408d1a265c67eed2a5c15acb50dd0b.zip
dev-perl/Coro: Bump to version 6.550.0
Upstream: - Fix compile with threaded perl - Simplify/speedup __DIE__ and __WARN__ handling - Add fixes for perl 5.22 compat (PadlistNAMES) - Add fixes for perl 5.24 compat (SUB_ARGARRAY) - Add fixes for perl 5.26 compat (PL_comppad -> PADOFFSET) - disable FORTIFY_SOURCE to avoid broken fortified longjmp on some libcs - Reattempt JIT allocation wtih PROT_EXEC to improve portability - Fix some statevar types for newer perls - safe_cancel no longer croaks when called on already-destroyed threads - libcoro now allows sharing coro threads using pthreads backend among different threads. - Always allow ->call and ->eval when coro is the current coroutine - Autogenerated Coro::AIO prototypes now add ";" to avoid creating named unary operators, to avoid `aio_mlockall 4 | 8` getting parsed as `(aio_mlockall 4) | 8` - Ensure Coro::RWLock wakes up all readers after a wrlock - More fixes for minix 3.3 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Coro/Coro-6.550.0.ebuild')
-rw-r--r--dev-perl/Coro/Coro-6.550.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Coro/Coro-6.550.0.ebuild b/dev-perl/Coro/Coro-6.550.0.ebuild
new file mode 100644
index 000000000000..7ba23ca2253e
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.550.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=6.55
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+LICENSE="|| ( Artistic GPL-1+ ) LGPL-2.1+ || ( BSD-2 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ev event"
+
+RDEPEND="
+ >=dev-perl/AnyEvent-7
+ ev? ( >=dev-perl/EV-4.0.0 )
+ event? ( >=dev-perl/Event-1.80.0 )
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+PATCHES=(
+ "${FILESDIR}/6.514.0-ev-config.patch"
+)
+src_configure() {
+ local myopts=()
+ use ev && myopts+=("EV")
+ use event && myopts+=( "Event" )
+ GENTOO_OPTS="${myopts[@]}" perl-module_src_configure
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}