summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-14 23:17:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-14 23:20:50 +0200
commit1dcf56af72461bf2961ebe6de5b220cffa289161 (patch)
treef07bc936f098ac0f8a52ba8eef7702e5f1b37bf8 /dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild
parentdev-perl/CPAN-DistnameInfo: EAPI=8 bump (diff)
downloadgentoo-1dcf56af72461bf2961ebe6de5b220cffa289161.tar.gz
gentoo-1dcf56af72461bf2961ebe6de5b220cffa289161.tar.bz2
gentoo-1dcf56af72461bf2961ebe6de5b220cffa289161.zip
dev-perl/Cpanel-JSON-XS: Version bump 4.27
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild')
-rw-r--r--dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild
new file mode 100644
index 000000000000..a7438bb6d3c3
--- /dev/null
+++ b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.270.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=4.27
+DIST_EXAMPLES=("eg/*")
+DIST_WIKI="tests"
+inherit perl-module
+
+DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.160.0
+ virtual/perl-Carp
+ >=virtual/perl-Encode-1.980.100
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+ >=virtual/perl-podlators-2.80.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ virtual/perl-Time-Piece
+ )
+"
+
+pkg_postinst() {
+ ewarn "This package provides 'cpanel_json_xs' in PATH, which includes optional features"
+ ewarn "otherwise not automatically made available yet. If you desire to use these,"
+ ewarn "please consult:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Optional_Features"
+}