summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-19 11:46:12 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-19 11:46:12 +1300
commitdcfb027f22c06af5da903a0cca198591e336dbcf (patch)
tree4dd19350a7cba17d5ca9b59f70deac0c908d9e55 /dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild
parentdev-perl/Crypt-CipherSaber: Add remote-id's to metadata.xml (diff)
downloadgentoo-dcfb027f22c06af5da903a0cca198591e336dbcf.tar.gz
gentoo-dcfb027f22c06af5da903a0cca198591e336dbcf.tar.bz2
gentoo-dcfb027f22c06af5da903a0cca198591e336dbcf.zip
dev-perl/Crypt-DES: EAPI6 + Test love
- EAPI6 - Tests enabled - Test deps added Keywords: - Dropped arm due to Crypt-CBC Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild
new file mode 100644
index 000000000000..283b274257d9
--- /dev/null
+++ b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.07
+inherit perl-module
+
+DESCRIPTION="Perl DES encryption module"
+
+LICENSE="DES"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="test? ( dev-perl/Crypt-CBC )"
+
+export OPTIMIZE="${CFLAGS}"