summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-02 00:41:49 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-02 00:43:09 +1200
commitb1190532af2d4462584e7bcf239bdea2cad7e7f8 (patch)
tree6b31fbeab8d495a5c0be443c786a6ba4700c1dff /dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild
parentdev-libs/libjcat: support python3_9, make vala bindings optional (diff)
downloadgentoo-b1190532af2d4462584e7bcf239bdea2cad7e7f8.tar.gz
gentoo-b1190532af2d4462584e7bcf239bdea2cad7e7f8.tar.bz2
gentoo-b1190532af2d4462584e7bcf239bdea2cad7e7f8.zip
dev-perl/Crypt-OpenSSL-EC: Bump to version 1.320.0
- EAPI7 - Ensure CFLAGS passed to compiler via make Upstream: - Rework Makefile.PL to work more like dev-perl/Crypt-OpenSSL-Bignum, which improves the linking situation on various platforms. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild')
-rw-r--r--dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild b/dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild
new file mode 100644
index 000000000000..8e382c37015f
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-EC/Crypt-OpenSSL-EC-1.320.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MIKEM
+DIST_VERSION=1.32
+inherit perl-module
+
+DESCRIPTION="Perl extension for OpenSSL EC (Elliptic Curves) library"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test libressl"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Crypt-OpenSSL-Bignum-0.40.0
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+"
+DEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}