summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-11 22:01:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-11 22:01:44 +0200
commit32c93ce0dd422038255b918143e7703e4613386c (patch)
tree8eadef7457f6609748234c0914007a6fdecad325 /dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild
parentdev-perl/Crypt-Rijndael: Version bump 1.16 (diff)
downloadgentoo-32c93ce0dd422038255b918143e7703e4613386c.tar.gz
gentoo-32c93ce0dd422038255b918143e7703e4613386c.tar.bz2
gentoo-32c93ce0dd422038255b918143e7703e4613386c.zip
dev-perl/Crypt-RIPEMD160: Version bump 0.08
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild')
-rw-r--r--dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild
new file mode 100644
index 000000000000..1f2c97ca4e1a
--- /dev/null
+++ b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.80.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Perl extension for the RIPEMD-160 Hash function"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}