summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Crypt-Random-Source
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Crypt-Random-Source')
-rw-r--r--dev-perl/Crypt-Random-Source/Crypt-Random-Source-0.70.0-r1.ebuild30
-rw-r--r--dev-perl/Crypt-Random-Source/Manifest1
-rw-r--r--dev-perl/Crypt-Random-Source/metadata.xml20
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Random-Source/Crypt-Random-Source-0.70.0-r1.ebuild b/dev-perl/Crypt-Random-Source/Crypt-Random-Source-0.70.0-r1.ebuild
new file mode 100644
index 000000000000..686a2420cfc2
--- /dev/null
+++ b/dev-perl/Crypt-Random-Source/Crypt-Random-Source-0.70.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NUFFIN
+MODULE_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Get weak or strong random data from pluggable sources"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Any-Moose-0.11
+ >=dev-perl/Capture-Tiny-0.08
+ dev-perl/Module-Find
+ dev-perl/Sub-Exporter
+ >=dev-perl/namespace-clean-0.08
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Exception
+ || ( >=virtual/perl-Test-Simple-1.1.10 dev-perl/Test-use-ok )
+ )"
+
+SRC_TEST="do"
diff --git a/dev-perl/Crypt-Random-Source/Manifest b/dev-perl/Crypt-Random-Source/Manifest
new file mode 100644
index 000000000000..db6dc78888c4
--- /dev/null
+++ b/dev-perl/Crypt-Random-Source/Manifest
@@ -0,0 +1 @@
+DIST Crypt-Random-Source-0.07.tar.gz 18883 SHA256 bbe19a6ee24ce8d4aacbcf9179b2b3477a729eccbdfa78ad8330413b2fc3ac4f SHA512 b6d075e89914237262432f933916046151d6d24b19b19c2185f2aaabd166ce3cda2505ff12c3be35c76b48c532fcfdf056fd8a7c2627f48c58817b6c42ce871b WHIRLPOOL 908fc1009829909b4097999bc035ebe6b3abb1ad671ff6913b83f9958467525035d4cd4580a82387ff96101e6b07597c640abfeafe2f8dc208d392281102a403
diff --git a/dev-perl/Crypt-Random-Source/metadata.xml b/dev-perl/Crypt-Random-Source/metadata.xml
new file mode 100644
index 000000000000..476ad6932bbc
--- /dev/null
+++ b/dev-perl/Crypt-Random-Source/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Crypt-Random-Source</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Base</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Base::File</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Base::Handle</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Base::Proc</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Base::RandomDevice</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Factory</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Strong</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Strong::devrandom</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Weak</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Weak::devurandom</remote-id>
+ <remote-id type="cpan-module">Crypt::Random::Source::Weak::rand</remote-id>
+ </upstream>
+</pkgmetadata>