summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-11 21:59:06 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-11 21:59:06 +0200
commit584b1ff1f6f0a733ad9d63913d823c5c6e4885f3 (patch)
treeb43f518a7ecf88b95194be3d828ff979063e9162 /dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild
parentdev-perl/Crypt-RC4: Remove old (diff)
downloadgentoo-584b1ff1f6f0a733ad9d63913d823c5c6e4885f3.tar.gz
gentoo-584b1ff1f6f0a733ad9d63913d823c5c6e4885f3.tar.bz2
gentoo-584b1ff1f6f0a733ad9d63913d823c5c6e4885f3.zip
dev-perl/Crypt-Rijndael: Version bump 1.16
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild')
-rw-r--r--dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild b/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild
new file mode 100644
index 000000000000..fbd9bf32d97c
--- /dev/null
+++ b/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.160.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="Crypt::CBC compliant Rijndael encryption module"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}