summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-25 05:02:18 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-25 05:02:48 +0200
commitc176d67e2c12b83c38a2e44897d6d0e0780c690e (patch)
tree0d6e3d516506a4580bcdb8bbcf6ccbaa4d2b3814 /dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild
parentapp-admin/salt: Version bump to 2019.2.2 (diff)
downloadgentoo-c176d67e2c12b83c38a2e44897d6d0e0780c690e.tar.gz
gentoo-c176d67e2c12b83c38a2e44897d6d0e0780c690e.tar.bz2
gentoo-c176d67e2c12b83c38a2e44897d6d0e0780c690e.zip
dev-perl/Crypt-SMIME: Version bump to 0.25
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild')
-rw-r--r--dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild
new file mode 100644
index 000000000000..61f476d4edb6
--- /dev/null
+++ b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIKAGE
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="S/MIME message signing, verification, encryption and decryption"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl test minimal"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.9:0 )
+ libressl? ( dev-libs/libressl )
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/ExtUtils-CChecker
+ >=virtual/perl-ExtUtils-Constant-0.230.0
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ !minimal? (
+ >=dev-perl/Test-Taint-1.60.0
+ >=dev-perl/Taint-Util-0.80.0
+ )
+ )
+"
+
+src_test() {
+ perl_rm_files t/boilerplate.t t/manifest.t t/dependencies.t \
+ t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}