summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Crypt-SSLeay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Crypt-SSLeay')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.640.0.ebuild34
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild41
-rw-r--r--dev-perl/Crypt-SSLeay/Manifest2
-rw-r--r--dev-perl/Crypt-SSLeay/metadata.xml16
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.640.0.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.640.0.ebuild
new file mode 100644
index 000000000000..4cc69e67bfa4
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.640.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NANIS
+MODULE_VERSION=0.64
+inherit perl-module
+
+DESCRIPTION="Crypt::SSLeay module for perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Disabling tests for now. Opening a port always leads to mixed results for
+# folks - bug 59554
+# nb. Re-enabled tests, seem to be better written now, keeping an eye on bugs
+# for this though.
+SRC_TEST="do"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7c:0
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Try-Tiny )"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="dev-perl/libwww-perl"
+
+export OPTIMIZE="${CFLAGS}"
+#myconf="--lib=${EPREFIX}/usr"
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild
new file mode 100644
index 000000000000..4b613c93fce3
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NANIS
+MODULE_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7c:0
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ >=dev-perl/Try-Tiny-0.190.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+export OPTIMIZE="${CFLAGS}"
+#myconf="--lib=${EPREFIX}/usr"
+
+SRC_TEST=do
diff --git a/dev-perl/Crypt-SSLeay/Manifest b/dev-perl/Crypt-SSLeay/Manifest
new file mode 100644
index 000000000000..de8271fc6a00
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Manifest
@@ -0,0 +1,2 @@
+DIST Crypt-SSLeay-0.64.tar.gz 121431 SHA256 eae61cf7aa64d79385b764010d8d77d09477e034c52fc3dfe68d0a13be78217c SHA512 2530a62f13154e2ce8a55e845dbc3dc2822420d56631ff64de2fd71c6cad5ddaa5e779070e7929f797a3fb09d004e31a9097bba0616d396abcb79aca710fa9eb WHIRLPOOL 4ddccd0cde43bb5c2a3c1f3bd59e221c758c0b31ba9f24b1fbc0fec40dbc2a98cc1a7da1a072af588379f6504b3e7c52a3b101a650005c2784ef34005adb4a19
+DIST Crypt-SSLeay-0.72.tar.gz 129575 SHA256 f5d34f813677829857cf8a0458623db45b4d9c2311daaebe446f9e01afa9ffe8 SHA512 af7a2878df94e116e9aad9a0f028f2e4f89074aaf31672915162f86e55211632d65c1cb00f3ebd25644d77adf8eecdd244dba6a004d93ab90289ab34fe4caaf4 WHIRLPOOL 9a6adb48d3c54b9242473a3c0585f7cf29ec5ef518e5826477778e3b0a2ce96785afc490af3bcb1b7499fc00f4fc6c032c73c3baa72aff37ce0cf18c51c1250a
diff --git a/dev-perl/Crypt-SSLeay/metadata.xml b/dev-perl/Crypt-SSLeay/metadata.xml
new file mode 100644
index 000000000000..5e3201a4b12a
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Crypt-SSLeay</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay::CTX</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay::Conn</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay::Err</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay::MainContext</remote-id>
+ <remote-id type="cpan-module">Crypt::SSLeay::X509</remote-id>
+ <remote-id type="cpan-module">DB</remote-id>
+ <remote-id type="cpan-module">Net::SSL</remote-id>
+ </upstream>
+</pkgmetadata>