summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-21 09:08:29 +0100
committerSam James <sam@gentoo.org>2023-06-21 09:17:35 +0100
commit923d45c40a784824d527b449c398654b7f355acd (patch)
treed9135515a60ab47fa529369f2f229a750d8e8274 /dev-perl/CryptX/CryptX-0.78.0.ebuild
parentdev-perl/Crypt-X509: add 0.550.0 (diff)
downloadgentoo-923d45c40a784824d527b449c398654b7f355acd.tar.gz
gentoo-923d45c40a784824d527b449c398654b7f355acd.tar.bz2
gentoo-923d45c40a784824d527b449c398654b7f355acd.zip
dev-perl/CryptX: add 0.78.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/CryptX/CryptX-0.78.0.ebuild')
-rw-r--r--dev-perl/CryptX/CryptX-0.78.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/CryptX/CryptX-0.78.0.ebuild b/dev-perl/CryptX/CryptX-0.78.0.ebuild
new file mode 100644
index 000000000000..47c6a2b7eb38
--- /dev/null
+++ b/dev-perl/CryptX/CryptX-0.78.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: unbundle libtommath, libtomcrypt. There's experimental support upstream.
+# bug #732634
+
+DIST_AUTHOR=MIK
+DIST_VERSION=0.078
+inherit perl-module
+
+DESCRIPTION="Self-contained crypto toolkit"
+
+LICENSE="|| ( Artistic GPL-1+ ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ virtual/perl-Math-BigInt
+ !minimal? (
+ dev-perl/JSON
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ !minimal? (
+ >=virtual/perl-Math-BigInt-1.999.715
+ >=virtual/perl-Storable-2.0.0
+ )
+ )
+"
+
+PERL_RM_FILES=(
+ t/002_all_pm.t
+ t/003_all_pm_pod.t
+ t/004_all_pm_pod_spelling.t
+ t/005_all_pm_pod_coverage.t
+)
+
+#src_configure() {
+# CRYPTX_LDFLAGS='-ltommath -ltomcrypt' perl-module_src_configure
+#}