summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 07:35:28 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 07:35:48 +1200
commit3d0e8f9e4feb745d8ee0e423752e61cc20513a46 (patch)
tree552e791d9ba5fb1fdee86b76425d90d431f024cb /dev-perl/Curses-UI
parentdev-python/pynvim: relax neovim dep (diff)
downloadgentoo-3d0e8f9e4feb745d8ee0e423752e61cc20513a46.tar.gz
gentoo-3d0e8f9e4feb745d8ee0e423752e61cc20513a46.tar.bz2
gentoo-3d0e8f9e4feb745d8ee0e423752e61cc20513a46.zip
dev-perl/Curses-UI: -r bump for EAPI7 + fixes
- EAPI7 - Unconditionally patch out bad tests - Move 'sed' to 'patch' Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Curses-UI')
-rw-r--r--dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild30
-rw-r--r--dev-perl/Curses-UI/files/Curses-UI-0.9609-no-dot-inc.patch22
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild b/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild
new file mode 100644
index 000000000000..04c46804b2c4
--- /dev/null
+++ b/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MDXI
+DIST_VERSION=0.9609
+inherit perl-module
+
+DESCRIPTION="Perl UI framework based on the curses library"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Curses
+ dev-perl/TermReadKey
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9609-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ t/05pod.t
+)
diff --git a/dev-perl/Curses-UI/files/Curses-UI-0.9609-no-dot-inc.patch b/dev-perl/Curses-UI/files/Curses-UI-0.9609-no-dot-inc.patch
new file mode 100644
index 000000000000..29027bccc8be
--- /dev/null
+++ b/dev-perl/Curses-UI/files/Curses-UI-0.9609-no-dot-inc.patch
@@ -0,0 +1,22 @@
+From 161a0a10c190de155e53d08f413aa49d4a4780e9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 3 Jul 2020 07:28:17 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 0084c7b..d84c838 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,4 +1,5 @@
+ # Load the Module::Install bundled in ./inc/
++use lib '.';
+ use inc::Module::Install;
+
+ # Define metadata
+--
+2.27.0
+