summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-15 07:13:45 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-15 07:13:45 -0400
commit89d0e9b74f73355e0b26187db60c1f1d182494cc (patch)
tree6e29e601919f2d57f7acffd46ac5ca8407fc2a27 /dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
parentmedia-libs/harfbuzz-1.4.6-r2: add amd64 keyword (diff)
downloadgentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.tar.gz
gentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.tar.bz2
gentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.zip
dev-perl/DBD-Pg: Version Bump to 3.6.2
Version bump enables building against >=dev-db/postgresql-10. Bugs: 624974 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
new file mode 100644
index 000000000000..da68ebc2ce4d
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# testcases require a local database with an
+# open password for the postgres user.
+DIST_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}