summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-23 03:44:14 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-23 15:24:58 +0200
commit72d9b29b136954aaf21e38f1fba3cbb790a602f4 (patch)
treee47477ce1fafa66bf42bb5987a10d8a2efb6f1e0 /dev-perl/DBD-Pg
parentsci-visualization/scidavis: add missing die on the heredoc (diff)
downloadgentoo-72d9b29b136954aaf21e38f1fba3cbb790a602f4.tar.gz
gentoo-72d9b29b136954aaf21e38f1fba3cbb790a602f4.tar.bz2
gentoo-72d9b29b136954aaf21e38f1fba3cbb790a602f4.zip
dev-perl/DBD-Pg: Remove old
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild44
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild97
-rw-r--r--dev-perl/DBD-Pg/Manifest2
3 files changed, 0 insertions, 143 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
deleted file mode 100644
index ab20f333f4a0..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-
-# testcases require a local database with an
-# open password for the postgres user.
-DIST_TEST="skip"
-
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild
deleted file mode 100644
index 697dbdda80b2..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
-
-src_test() {
- local MODULES=(
- # Compile failure: https://rt.cpan.org/Ticket/Display.html?id=123218
- # "Bundle::DBD::Pg v${PV}"
- "DBD::Pg v${PV}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1 #||
- #die "Could not load ${dep}"
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
-
- local LIVEDB_TESTS=(
- "t/01connect.t"
- "t/02attribs.t"
- "t/03dbmethod.t"
- "t/03smethod.t"
- "t/04misc.t"
- "t/06bytea.t"
- "t/07copy.t"
- "t/08async.t"
- "t/09arrays.t"
- "t/12placeholders.t"
- "t/20savepoints.t"
- "t/30unicode.t"
- )
- local SKIP_TESTS=(
- "t/00_signature.t"
- );
- if [[ ! -v DBI_DSN ]]; then
- ewarn "Functional database tests disabled due to lack of configuration."
- ewarn "Please set the following environment variables values pertaining to a"
- ewarn "pre-configured Postgres installation in order for tests to work:"
- ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
- ewarn " ( eg: dbi:Pg:dbname=testdb )"
- ewarn " DBI_USER - A Postgres Database Username"
- ewarn " DBI_PASS - A Postgres Database Password"
- ewarn ""
- ewarn "For details, visit:"
- ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
- SKIP_TESTS+=( "${LIVEDB_TESTS[@]}" )
- fi
- perl_rm_files "${SKIP_TESTS[@]}"
- # Parallel testing breaks database access
- DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
-
-}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index 2804fc8467b6..7ec7344b9c7a 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1,4 +1,2 @@
DIST DBD-Pg-3.10.0.tar.gz 268414 BLAKE2B da6ac65519632aa95ee2554607d5e26820527042873ab78a9e40e671902b1b8e2fe39f37e44b15cf3db8eda243e57c7fab9077d4a08ec7f3c312825609fbc805 SHA512 46c985bbdeeed4ef60d6fe06034fa0959df288f2b9bbd434e2716676a3cb7a1ded168a3cf87a6a82eb397eb8edcc023c0b85483e948ce31abcac64a1919580ba
DIST DBD-Pg-3.14.2.tar.gz 282024 BLAKE2B a8121a2c97b1e095576c40b9b305f0ac21b3a8062efd3ac9684ef68346fc9fb0e4384780dc79b7bb5b6b188825dbd2f3da4765eeeb0208c3bef4db28543f9021 SHA512 341df267a7dc1e28f8c71c1b03cb485caf5c9c2ba95a801f7e855ef8c2fb2ed2df2f3cef804fd36072ee5570d30b399f6fba7516216f7d24186c5b6eeb5d5c52
-DIST DBD-Pg-3.5.3.tar.gz 256570 BLAKE2B f589fc4ed978d2215d66b4cfd72b00e166f15dbe2caf004fa52c09fc6fc9f9b81ed84bc04ec0c4d3fe15f4eabb5a8a3b24b08acabb66b993c3ce67576a4c1721 SHA512 7a564e5c86fa41719289f6e391f0cd39f01df7d088892fca11175c60fec8a3af884f9204ae834caac2024ff0d45dcc013e314ec0c09a07fe7ee76170ec3a634f
-DIST DBD-Pg-3.7.0.tar.gz 260083 BLAKE2B 73ae253e8033dab58075f6dc3c639e5d21f2df09880f59cb00fcdc201c17db1573e4902c4bfd535916775c0ef61a020a70e8f542ce28e257a903d4aabb9f6730 SHA512 edd4d3448dac1b563899c5fd4a1bad6cb810afdbbbf57b558bbe6710aa3e58530a6cf0932e35c3316c7f4f59763764d75ce1049f13c8c13deeb2e8a7c60ff73e