summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-05-05 00:20:48 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-07 00:30:09 +0200
commitabbd5bc1fb887a69220b3e1c70520c15eb0c55bd (patch)
tree1c5c62b97a8bdfdc17fe8adbc22ed546ff23d2d7 /dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild
parentdev-perl/Plack: Patch tests to avoid parallel-testing race-condition. (diff)
downloadgentoo-abbd5bc1fb887a69220b3e1c70520c15eb0c55bd.tar.gz
gentoo-abbd5bc1fb887a69220b3e1c70520c15eb0c55bd.tar.bz2
gentoo-abbd5bc1fb887a69220b3e1c70520c15eb0c55bd.zip
dev-perl/DBD-SQLite: Bump to version 1.500.0
- EAPI6 - Moved the use of system-sqlite into a USE="system-sqlite" useflag, as compiling against all present versions of dev-db/sqlite results in test failres that don't occur with the native version. Said Useflag is also off by default for that reason. Upstream: - Updated to bundled SQLite 3.10.2 - Added a ReadOnly connection flag. - General improvments in ::Constants conveniences. - Some bugs fixed in savepoint handling - allow_multiple_statements retains contents of unprepared_statements Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild')
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild
new file mode 100644
index 000000000000..83dd994ecbce
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=1.50
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test system-sqlite"
+
+# NB: Get min sqlite version from sqlite3.c
+RDEPEND="
+ system-sqlite? (
+ >=dev-db/sqlite-3.10.2[extensions(+)]
+ )
+ >=dev-perl/DBI-1.570.0
+ !<dev-perl/DBD-SQLite-1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ if use system-sqlite; then
+ einfo "Removing bundled SQLite"
+ # Flip Makefile into system mode.
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+ fi
+}