summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-23 21:09:43 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-24 14:50:42 +1300
commit19eeb140a84c8bb903b808bf7ea344a3c633857a (patch)
tree7e363e225fb58475b4aa42792cd2a09695af9210 /dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild
parentgames-action/rafkill: remove deprecated games eclass (diff)
downloadgentoo-19eeb140a84c8bb903b808bf7ea344a3c633857a.tar.gz
gentoo-19eeb140a84c8bb903b808bf7ea344a3c633857a.tar.bz2
gentoo-19eeb140a84c8bb903b808bf7ea344a3c633857a.zip
dev-perl/DBD-mysql: Security cleanup re bug #601144
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild
deleted file mode 100644
index 46fdcf6e7984..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-DIST_AUTHOR=MICHIELB
-DIST_VERSION=4.037
-inherit eutils perl-module
-
-DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-# embedded=on disables ssl support
-# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
-REQUIRED_USE="?? ( embedded ssl )"
-IUSE="embedded test +ssl"
-
-RDEPEND=">=dev-perl/DBI-1.609.0
- virtual/libmysqlclient:=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Data-Dumper
- test? (
- dev-perl/Test-Deep
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-print_embedded_options.patch
-)
-
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf="${myconf} --$(usex ssl ssl nossl)"
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-# Parallel testing is broken as 2 tests create the same table
-# and mysql isn't acid compliant and can't limit visibility of tables
-# to a transaction...
-DIST_TEST="do"
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl_rm_files t/pod.t t/manifest.t
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}