summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-06 22:07:59 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-06 22:08:37 +1300
commit83dde078362b66346e7bb659ef8cf250f548eb1b (patch)
tree6a0cfa1eaf43a505a24e2c711580d6198405007e /dev-perl/DBI/DBI-1.636.0.ebuild
parentapp-office/scribus: Fix dos2unix incompatibility (diff)
downloadgentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.tar.gz
gentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.tar.bz2
gentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.zip
dev-perl/DBI: Bump to version 1.636.0
- EAPI6 - Add USE="examples" - Removed restriction on parallel compilation and tests Upstream: - Fix compilation on threadperls <= 5.12 - Fix race condition in destroy tests - Handle UTF8 in RaiseError/PrintError correctly - Fix ShowErrorStatement showing the wrong statement - DBD::Gofer handles UTF8 STDIN/STDOUT correctly - Fix no-column fetchall_arrayref({}) failing to bind_columns by returning an empty set instead - Fix memory leak with tied CachedKids attribute cache - Fix commit() or rollback() raising fatal "panic: attempt to copy freed scalar" in non-null context. - Avoid spurious extra warning when passing undef to DBI::Profile as a Path. - SQL::Nano parser now ignores trailing semicolon - New dbh->selectall_array method akin for simplifed dereferencing. - Killed DBI::FAQ Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DBI/DBI-1.636.0.ebuild')
-rw-r--r--dev-perl/DBI/DBI-1.636.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/DBI/DBI-1.636.0.ebuild b/dev-perl/DBI/DBI-1.636.0.ebuild
new file mode 100644
index 000000000000..a73e925d6447
--- /dev/null
+++ b/dev-perl/DBI/DBI-1.636.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=1.636
+DIST_EXAMPLES=("ex/*")
+inherit perl-module eutils
+
+DESCRIPTION="Database independent interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/PlRPC-0.200.0
+ >=virtual/perl-Sys-Syslog-0.170.0
+ virtual/perl-File-Spec
+ !<=dev-perl/SQL-Statement-1.330.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}