summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-30 02:38:15 +0100
committerSam James <sam@gentoo.org>2024-04-30 02:38:35 +0100
commit749667b8738e67580fae7c09f2c0e05410f4c3e1 (patch)
tree47e4600014e2db37db8c1a7fe4b7e11c7a588862 /dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild
parentdev-perl/Data-Printer: add 1.2.1 (diff)
downloadgentoo-749667b8738e67580fae7c09f2c0e05410f4c3e1.tar.gz
gentoo-749667b8738e67580fae7c09f2c0e05410f4c3e1.tar.bz2
gentoo-749667b8738e67580fae7c09f2c0e05410f4c3e1.zip
dev-perl/Data-UUID: add 1.227.0
Bug: https://bugs.gentoo.org/479370 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild')
-rw-r--r--dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild b/dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild
new file mode 100644
index 000000000000..669f2cdad7d1
--- /dev/null
+++ b/dev-perl/Data-UUID/Data-UUID-1.227.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=GTERMARS
+DIST_VERSION=1.227
+inherit perl-module
+
+DESCRIPTION="Generate Globally/Universally Unique Identifiers (GUIDs/UUIDs)"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)