summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-25 02:11:55 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-25 02:11:55 +1300
commitb1ac1f844d3d3ae1fcbd708daf8d20dc3457c7aa (patch)
tree01a42d56d823d804332b3c5a367fec12774d59e7 /dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild
parentdev-perl/DateTime-TimeZone: Remove old masked versions (diff)
downloadgentoo-b1ac1f844d3d3ae1fcbd708daf8d20dc3457c7aa.tar.gz
gentoo-b1ac1f844d3d3ae1fcbd708daf8d20dc3457c7aa.tar.bz2
gentoo-b1ac1f844d3d3ae1fcbd708daf8d20dc3457c7aa.zip
dev-perl/DateTime-Format-Flexible: Bump to version 0.280.0 re bug #613590
Upstream: - Fix '.' in @INC issues Bug: https://bugs.gentoo.org/613590 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild
new file mode 100644
index 000000000000..d14afe324c37
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=THINC
+DIST_VERSION=0.28
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.740.0
+ dev-perl/DateTime-TimeZone
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Pluggable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.440.0
+ )
+"
+src_test() {
+ perl_rm_files t/002_pod.t t/003_podcoverage.t
+ perl-module_src_test
+}