summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-16 13:22:05 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-16 13:28:46 +0200
commit43fce2dce571f07ce14b750e0eef05ddbefe3844 (patch)
tree8a4bb1f77e7abe437bc84ae9efaa8195b4aa76ce /dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild
parentdev-perl/Date-Simple: Remove old (diff)
downloadgentoo-43fce2dce571f07ce14b750e0eef05ddbefe3844.tar.gz
gentoo-43fce2dce571f07ce14b750e0eef05ddbefe3844.tar.bz2
gentoo-43fce2dce571f07ce14b750e0eef05ddbefe3844.zip
dev-perl/DateTime-TimeZone: Version bump 2.47
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild')
-rw-r--r--dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild
new file mode 100644
index 000000000000..13db9b84b709
--- /dev/null
+++ b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.470.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=2.47
+inherit perl-module
+
+DESCRIPTION="Time zone object base class and factory"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Singleton-1.30.0
+ >=virtual/perl-File-Spec-3.0.0
+ dev-perl/Module-Runtime
+ >=dev-perl/Params-ValidationCompiler-0.130.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=dev-perl/Specio-0.150.0
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"