summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:18 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:56 +1300
commit91f4c905162f99491d8a2db9376e14b2155c6f98 (patch)
treebcd57c0f1eafeb4ee9bcc86da05e6872ee71e3bc /dev-perl/DateTime/DateTime-1.280.0.ebuild
parentdev-perl/DateTime-Locale: Bump to 1.30.0 (diff)
downloadgentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.tar.gz
gentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.tar.bz2
gentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.zip
dev-perl/DateTime: Bump to 1.280.0
This is the last version we can bump to without needing to warp to Test2 infrastructure. Upstream: - Fix problems with floating point epoch handling - Added support for PERL_DATETIME_DEFAULT_TZ ENV flag - Migrated to EUMM - DateTime->from_object(DateTime::Infinite) now returns DateTime::Infinite - DateTime::Infinite returns system representation of positive/ negative infinity for methods like year(), month(), etc. - Support negative and scientific-notation values for from_epoch Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DateTime/DateTime-1.280.0.ebuild')
-rw-r--r--dev-perl/DateTime/DateTime-1.280.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.280.0.ebuild b/dev-perl/DateTime/DateTime-1.280.0.ebuild
new file mode 100644
index 000000000000..5f5e013c8dd9
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.280.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.28
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-0.410.0
+ >=dev-perl/DateTime-TimeZone-1.740.0
+ >=dev-perl/Params-Validate-1.30.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"