summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-25 21:06:34 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-25 21:07:19 +1200
commit5af56a7c9fb7a22ebe38fa36cf93684580667048 (patch)
treece4ec7940704788825b25f09c4323f434cb3438d /dev-perl/DateTime/DateTime-1.520.0.ebuild
parentdev-ruby/childprocess: remove unused patch(es) (diff)
downloadgentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.tar.gz
gentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.tar.bz2
gentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.zip
dev-perl/DateTime: Bump to version 1.520.0
- EAPI7 - Ensure CFLAGS passed to compiler Upstream: - Add methods ->{month,quarter,year}_length() - Fixed formatting of CLDR "S" to truncate instead of rounding up to one. - Duration->multiply() now only allows integer multipliers - Add methods ->is_last_day_of{quarter,year} - Fix bad temporary state of duration after internal exceptions - Fix compile on 5.27.11 - Add method dt->is_between($a,$b) - Simplify XS calculation of leap seconds Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DateTime/DateTime-1.520.0.ebuild')
-rw-r--r--dev-perl/DateTime/DateTime-1.520.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.520.0.ebuild b/dev-perl/DateTime/DateTime-1.520.0.ebuild
new file mode 100644
index 000000000000..ae06828db4a1
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.520.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.52
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CONFLICTS="
+ !<=dev-perl/DateTime-Format-Mail-0.402.0
+"
+RDEPEND="
+ ${CONFLICTS}
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-1.60.0
+ >=dev-perl/DateTime-TimeZone-2.20.0
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Params-ValidationCompiler-0.260.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Specio-0.180.0
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+ >=dev-perl/namespace-autoclean-0.190.0
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-CPAN-Meta-Requirements
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}