summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-20 20:39:28 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-20 20:39:51 +1300
commitb5dfb800693ccbf78a0b90c1603ce6200af48228 (patch)
treee33f59b3c4050921a23b3d03a01d3ce4e30dda75 /dev-perl/Device-SerialPort
parentdev-perl/Dist-Zilla-Plugin-SurgicalPodWeaver: Add remote-id to metadata.xml (diff)
downloadgentoo-b5dfb800693ccbf78a0b90c1603ce6200af48228.tar.gz
gentoo-b5dfb800693ccbf78a0b90c1603ce6200af48228.tar.bz2
gentoo-b5dfb800693ccbf78a0b90c1603ce6200af48228.zip
dev-perl/Device-SerialPort: EAPI6 + Basic tests
- EAPI6 - Add compile tests - Fence/Document advanced testing - Add USE="examples" Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Device-SerialPort')
-rw-r--r--dev-perl/Device-SerialPort/Device-SerialPort-1.40.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/Device-SerialPort/Device-SerialPort-1.40.0-r2.ebuild b/dev-perl/Device-SerialPort/Device-SerialPort-1.40.0-r2.ebuild
new file mode 100644
index 000000000000..175ab8c6cee3
--- /dev/null
+++ b/dev-perl/Device-SerialPort/Device-SerialPort-1.40.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=COOK
+DIST_VERSION=1.04
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="A Serial port Perl Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+#From the module:
+# If you run 'make test', you must make sure that nothing is plugged
+# into '/dev/ttyS1'!
+# Doesn't sound wise to enable SRC_TEST="do" - mcummings
+
+src_configure() {
+ myconf=()
+ [[ -n "${DEVICE_SERIALPORT_PORT}" ]] && myconf+=( "TESTPORT=${DEVICE_SERIALPORT_PORT}" )
+ perl-module_src_configure
+}
+src_test() {
+ local MODULES=(
+ "Device::SerialPort ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if [[ -n "${DEVICE_SERIALPORT_PORT}" ]]; then
+ DIST_TEST="do"; # Parallel testing a serial port sounds unsmart.
+ perl-module_src_test;
+ else
+ ewarn "Functional tests are disabled without manual intervention."
+ ewarn "For details, read:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Device-SerialPort"
+ fi
+}