summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-17 01:31:20 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-17 04:55:21 +1200
commitea13fb6b6ee4420a09bd62dc7e5d4a5e80d6fd55 (patch)
tree49770950815c77e46b1520a65cf0d7bb1992e6a8 /dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild
parentgames-util/lutris: Added missing dep on dev-python/dbus-python (diff)
downloadgentoo-ea13fb6b6ee4420a09bd62dc7e5d4a5e80d6fd55.tar.gz
gentoo-ea13fb6b6ee4420a09bd62dc7e5d4a5e80d6fd55.tar.bz2
gentoo-ea13fb6b6ee4420a09bd62dc7e5d4a5e80d6fd55.zip
dev-perl/Dist-Zilla-Plugin-ContributorsFile: Add w/ v=0.3.0
Required by app-admin/rex-9999 Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild b/dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild
new file mode 100644
index 000000000000..fea34f0c2eb0
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-ContributorsFile/Dist-Zilla-Plugin-ContributorsFile-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=YANICK
+DIST_VERSION=0.3.0
+inherit perl-module
+
+DESCRIPTION="add a file listing all contributors"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-perl/Dist-Zilla
+ dev-perl/Moose
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"