summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-31 23:57:14 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-31 23:57:37 +1200
commit659fb509c8fb2fea8cb06f738e54f90b9e76c562 (patch)
treeadf68cb51bbda695d13a56337c450cfc82519da1 /dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild
parentsys-fs/udisks: USE="-daemon" still requires sys-libs/libblockdev (diff)
downloadgentoo-659fb509c8fb2fea8cb06f738e54f90b9e76c562.tar.gz
gentoo-659fb509c8fb2fea8cb06f738e54f90b9e76c562.tar.bz2
gentoo-659fb509c8fb2fea8cb06f738e54f90b9e76c562.zip
dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease: Bump to version 0.7.0
Upstream: - Various packaging updates Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild b/dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild
new file mode 100644
index 000000000000..524bd67c8ed2
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-CopyFilesFromRelease/Dist-Zilla-Plugin-CopyFilesFromRelease-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.007
+inherit perl-module
+
+DESCRIPTION="Copy files from a release (for SCM inclusion, etc.)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-perl/Dist-Zilla
+ dev-perl/Moose
+ >=dev-perl/Path-Tiny-0.70.0
+ dev-perl/namespace-autoclean
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-if
+ )
+"