summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-04 21:52:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-04 21:54:10 +1200
commit3805cad630b5465affd945d08ea92f9a37bf8945 (patch)
tree2a597f4257502e78760582cf44d87df472212b10 /dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild
parentsys-auth/pambase: Drop old (diff)
downloadgentoo-3805cad630b5465affd945d08ea92f9a37bf8945.tar.gz
gentoo-3805cad630b5465affd945d08ea92f9a37bf8945.tar.bz2
gentoo-3805cad630b5465affd945d08ea92f9a37bf8945.zip
dev-perl/Dist-Zilla-Plugin-RPM: Bump to version 0.16.0
- EAPI7 Upstream: - Fix broken IPC::Run::run call for push_command Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild b/dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild
new file mode 100644
index 000000000000..34667f9a569b
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-RPM/Dist-Zilla-Plugin-RPM-0.16.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SKYSYMBOL
+DIST_VERSION=0.016
+inherit perl-module
+
+DESCRIPTION="Build an RPM from your Dist::Zilla release"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Dist-Zilla
+ virtual/perl-File-Temp
+ dev-perl/IPC-Run
+ dev-perl/Moose
+ dev-perl/Moose-Autobox
+ dev-perl/Path-Class
+ dev-perl/Path-Tiny
+ dev-perl/Text-Template
+ dev-perl/namespace-autoclean
+ app-arch/rpm
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/File-Which
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"