summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-03 13:34:19 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-04 02:49:06 +1200
commit1517b718b46aafca9463f29baec3f8eb9ba3a070 (patch)
treea91ef13f0a39424902c93067a07b65b821ecb19a /dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild
parentdev-perl/Dist-Zilla-Plugin-ReversionOnRelease: Add w/v=0.60.0 (diff)
downloadgentoo-1517b718b46aafca9463f29baec3f8eb9ba3a070.tar.gz
gentoo-1517b718b46aafca9463f29baec3f8eb9ba3a070.tar.bz2
gentoo-1517b718b46aafca9463f29baec3f8eb9ba3a070.zip
dev-perl/Dist-Zilla-Plugin-StaticInstall: Add w/v=0.12.0
Required by dev-perl/Dist-Milla, useful for building dev-perl/App-cpanminus from git sources. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild b/dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild
new file mode 100644
index 000000000000..3e151824ccb6
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-StaticInstall/Dist-Zilla-Plugin-StaticInstall-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.012
+inherit perl-module
+
+DESCRIPTION="Identify a distribution as eligible for static installation"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Dist-Zilla-4.300.39
+ dev-perl/Moose
+ dev-perl/MooseX-Types
+ dev-perl/Path-Tiny
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=virtual/perl-Term-ANSIColor-3.0.0
+ dev-perl/autovivification
+ dev-perl/namespace-autoclean
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Module-Runtime
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-if
+ )
+"