summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-08 06:55:28 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-08 07:36:04 +1200
commit93f0c3ba015c3d4b0db14ff254311ef8a8e23748 (patch)
tree6e7f8d8744120a6023b6d3e2237a530076adb703 /dev-perl/EV/EV-4.330.0.ebuild
parentdev-python/matplotlib: Stabilize 3.2.2 ppc64, #733840 (diff)
downloadgentoo-93f0c3ba015c3d4b0db14ff254311ef8a8e23748.tar.gz
gentoo-93f0c3ba015c3d4b0db14ff254311ef8a8e23748.tar.bz2
gentoo-93f0c3ba015c3d4b0db14ff254311ef8a8e23748.zip
dev-perl/EV: Bump to version 4.330.0
- EAPI7 - Fixup LICENSE - Ensure CFLAGS passed to make/compiler - Note: I investigated the possibilitiy of using system libev, which is published by the same author, but it isn't currently possible due to the build code needing *c* files from libev directly, and I'm not sure how to decouple that reliably. Upstream: - Sync to (bundled) libev 4.31 - Fix an assertion with a typo - Avoid perl's assert() in more places due to it misbehaving - update libecb for windows environments - use the new ev_io_modify in EV::IO->events - Add mutator methods Timer->repeat, Periodic->{offset,interval,reschedule_cb} - Minor optimizations - Try to name `ev.h` more explicitly for portability - Opportunistic round-up of wait times in polling backends to avoid unneeded loop iterations - Fix minix 3.3 support - Allow users to re-enable assert() in case it is disabled by perl - Allow linux AIO backend to be used by default - Only use __register_atfork with glibc/uclibc, to avoid being broken on musl Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/EV/EV-4.330.0.ebuild')
-rw-r--r--dev-perl/EV/EV-4.330.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/EV/EV-4.330.0.ebuild b/dev-perl/EV/EV-4.330.0.ebuild
new file mode 100644
index 000000000000..4aba09327aae
--- /dev/null
+++ b/dev-perl/EV/EV-4.330.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.33
+inherit perl-module
+
+DESCRIPTION="Perl interface to libev, a high performance full-featured event loop"
+LICENSE=" || ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/common-sense
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Canary-Stability
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}