summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-08 16:51:16 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-08 16:51:16 +1300
commit4007fd0035bdfec0560a27c1c3f4abbc55390b4e (patch)
tree2544a7b5a7c1c5c8fe15a4fa66cf2d25f836c123 /dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
parentdev-perl/CPAN-Perl-Releases: Bump to version 3.40.0 (diff)
downloadgentoo-4007fd0035bdfec0560a27c1c3f4abbc55390b4e.tar.gz
gentoo-4007fd0035bdfec0560a27c1c3f4abbc55390b4e.tar.bz2
gentoo-4007fd0035bdfec0560a27c1c3f4abbc55390b4e.zip
dev-perl/Exception-Class: Bump to version 1.420.0
Upstream: - Properly mark generated exception classes in %INC so that subsequent "eval { require Foo }" statements ( such as found in "base.pm" ) don't trigger a disk load for those classes, shoring up potential attack surface against hostile code in "." under ". in @INC" usage. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
new file mode 100644
index 000000000000..f90213bb9576
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.42
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"