summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-24 20:11:48 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-24 20:24:38 +0200
commit6062414b1f5976a72add5d9bda7902a82e8b0ef3 (patch)
treeaf941c3d63a0e12bd47527ac254e50702eb45935 /dev-perl/ExtUtils-AutoInstall
parentdev-perl/Exporter-Tiny: Remove old (diff)
downloadgentoo-6062414b1f5976a72add5d9bda7902a82e8b0ef3.tar.gz
gentoo-6062414b1f5976a72add5d9bda7902a82e8b0ef3.tar.bz2
gentoo-6062414b1f5976a72add5d9bda7902a82e8b0ef3.zip
dev-perl/ExtUtils-AutoInstall: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/ExtUtils-AutoInstall')
-rw-r--r--dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0-r1.ebuild (renamed from dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild)14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0-r1.ebuild
index fdc6eb124e7e..b6b91bc57705 100644
--- a/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild
+++ b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DIST_AUTHOR=INGY
DIST_VERSION=0.64
@@ -11,22 +11,22 @@ DESCRIPTION="Automatic installation of dependencies via CPAN from within Makefil
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-IUSE=""
-# TESTS BAD. Wants to write to cpan's config on the live system
-#SRC_TEST="do"
-
-RDEPEND="dev-perl/Sort-Versions"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ dev-perl/Sort-Versions
+"
+BDEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-no-dot-inc.patch"
"${FILESDIR}/${P}-cpantest.patch"
)
+
src_compile() {
echo "n" | perl-module_src_compile
}
+
src_test() {
local MODULES=(
"ExtUtils::AutoInstall ${DIST_VERSION}"