summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-09 06:56:23 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-09 08:07:13 +1300
commit45959dab5e7fb1ed7914404fefdb64433c6d1aaf (patch)
tree3275286018371aeca1b852c6dcb47b30f1c0ca92 /dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild
parentdev-perl/ExtUtils-Helpers: Bump to version 0.26.0 (diff)
downloadgentoo-45959dab5e7fb1ed7914404fefdb64433c6d1aaf.tar.gz
gentoo-45959dab5e7fb1ed7914404fefdb64433c6d1aaf.tar.bz2
gentoo-45959dab5e7fb1ed7914404fefdb64433c6d1aaf.zip
dev-perl/ExtUtils-InstallPaths: Bump to 0.11.0
- EAPI6 - Parallel Tests Upstream: - Fixes for 5.6 compat - Minimum dependency on File::Spec added Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild')
-rw-r--r--dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild b/dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild
new file mode 100644
index 000000000000..aed317d4f749
--- /dev/null
+++ b/dev-perl/ExtUtils-InstallPaths/ExtUtils-InstallPaths-0.11.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.011
+inherit perl-module
+
+DESCRIPTION="Build.PL install path logic made easy"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/ExtUtils-Config-0.2.0
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-File-Spec-0.830.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/release-*.t
+ perl-module_src_test
+}