summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-26 19:54:21 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-26 19:57:00 +1200
commit404cb8afa526bfbab581e14e46252a733de08268 (patch)
treed673aeb22f0b20fe09bdfb6a62b0818eee679e70 /dev-perl/File-NFSLock
parentnet-libs/libmbim: keyword ~arm64 (diff)
downloadgentoo-404cb8afa526bfbab581e14e46252a733de08268.tar.gz
gentoo-404cb8afa526bfbab581e14e46252a733de08268.tar.bz2
gentoo-404cb8afa526bfbab581e14e46252a733de08268.zip
dev-perl/File-NFSLock: Fix for '.' in @INC re bug #615094
Fix use of 'do q[relativepath]' for 5.26 changes. Bug: https://bugs.gentoo.org/615094 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/File-NFSLock')
-rw-r--r--dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild4
-rw-r--r--dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch34
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild b/dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild
index dcdb074d3fcc..6496e7a37fb1 100644
--- a/dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild
+++ b/dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,5 +14,5 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/perl-ExtUtils-MakeMaker"
-
+PATCHES=( "${FILESDIR}/${PN}"-1.27-no-dot-inc.patch )
SRC_TEST="do"
diff --git a/dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch b/dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch
new file mode 100644
index 000000000000..9b67d24d10d6
--- /dev/null
+++ b/dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch
@@ -0,0 +1,34 @@
+From 08deb6590eecd9d92a38edf1b22d615175e1d8d3 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Mon, 26 Jun 2017 19:43:14 +1200
+Subject: [PATCH] Fix for '.' removal from Perl 5.26 @INC
+
+---
+ File-NFSLock.spec.PL | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/File-NFSLock.spec.PL b/File-NFSLock.spec.PL
+index fdf9fdf..f5586c1 100644
+--- a/File-NFSLock.spec.PL
++++ b/File-NFSLock.spec.PL
+@@ -18,7 +18,7 @@ sub WriteMakefile {
+ } elsif (my $version_from = $props{VERSION_FROM}) {
+ $@ = "";
+ $version = eval qq{
+- do "$version_from";
++ do "./$version_from";
+ \$$name\::VERSION || die "$version_from: Missing VERSION";
+ };
+ die $@ if $@;
+@@ -29,7 +29,7 @@ sub WriteMakefile {
+ die "Makefile.PL: Could not determine version!";
+ }
+ }
+-do "Makefile.PL";
++do "./Makefile.PL";
+ if ($name) {
+ $name =~ s/::/-/g;
+ } else {
+--
+2.13.1
+