summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-17 20:11:03 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-18 19:15:42 +1300
commit0486ccb6de93d929bc153e3128345832e2d25d6a (patch)
tree6def24efeb8ae2767a41fb399804d6ca8f8d5049 /dev-perl/File-Next/File-Next-1.160.0.ebuild
parentdev-lisp/clisp: add -falign-functions=4 on x86 (diff)
downloadgentoo-0486ccb6de93d929bc153e3128345832e2d25d6a.tar.gz
gentoo-0486ccb6de93d929bc153e3128345832e2d25d6a.tar.bz2
gentoo-0486ccb6de93d929bc153e3128345832e2d25d6a.zip
dev-perl/File-Next: Bump to version 1.160.0
- EAPI6 - Parallel Tests Upstream: - Fix tests failing in parallel - Switch META.license to Artistic-2 - from_file() no longer uses error_handler for warnings - from_file() no longer ignores warning_handler Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-perl/File-Next/File-Next-1.160.0.ebuild')
-rw-r--r--dev-perl/File-Next/File-Next-1.160.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.160.0.ebuild b/dev-perl/File-Next/File-Next-1.160.0.ebuild
new file mode 100644
index 000000000000..161a3c00122e
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.160.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="File::Next is an iterator-based module for finding files"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}