summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-10 12:28:08 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-10 12:38:07 -0500
commit3c07d3f4987c5b1a339dcf99400a097340fe6631 (patch)
tree652a5ee931018ce37ae9b2edfcd4079f69c2646f /dev-perl/File-Next/File-Next-1.180.0.ebuild
parentdev-ros/gazebo_plugins: fix build with opencv4 (diff)
downloadgentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.tar.gz
gentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.tar.bz2
gentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.zip
dev-perl/File-Next: Version bump to 1.180.0
Ack-by: dilfridge@gentoo.org Closes: https://bugs.gentoo.org/700684 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-perl/File-Next/File-Next-1.180.0.ebuild')
-rw-r--r--dev-perl/File-Next/File-Next-1.180.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.180.0.ebuild b/dev-perl/File-Next/File-Next-1.180.0.ebuild
new file mode 100644
index 000000000000..08bbf5784efe
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.180.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.18
+inherit perl-module
+
+DESCRIPTION="File::Next is an iterator-based module for finding files"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+RESTRICT="!test? ( test )"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}