summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-05 18:12:44 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-05 18:13:03 +1200
commit6e33cbd0b02798ba341763bdeb17a69b773ff513 (patch)
tree813f9a6043531f48930856ef40c47ab02366c9d0 /dev-perl/File-Next
parentsci-chemistry/gromacs: add release 2016 (diff)
downloadgentoo-6e33cbd0b02798ba341763bdeb17a69b773ff513.tar.gz
gentoo-6e33cbd0b02798ba341763bdeb17a69b773ff513.tar.bz2
gentoo-6e33cbd0b02798ba341763bdeb17a69b773ff513.zip
dev-perl/File-Next: Remove POD dependency
Normally the dependent tests could be nuked, but the test suite is dependent on various files for testing iteration of files. So the POD tests are replaced with no-op tests that simply pass as fast as possible, so that the Pod testing can be nuked and the dependencies can be reaped Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/File-Next')
-rw-r--r--dev-perl/File-Next/File-Next-1.120.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-perl/File-Next/File-Next-1.120.0-r1.ebuild b/dev-perl/File-Next/File-Next-1.120.0-r1.ebuild
index 1e2269bf3921..d3dfe98cb2e0 100644
--- a/dev-perl/File-Next/File-Next-1.120.0-r1.ebuild
+++ b/dev-perl/File-Next/File-Next-1.120.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,9 +17,13 @@ IUSE="test"
RDEPEND="virtual/perl-File-Spec
virtual/perl-Test-Simple"
DEPEND="
- test? ( ${RDEPEND}
- dev-perl/Test-Pod
- dev-perl/Test-Pod-Coverage
- )"
+ test? ( ${RDEPEND} )"
SRC_TEST=do
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}