summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-05 23:55:17 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-05 23:56:55 +1200
commitb7f5f75ce9b6d9a867b0aae67f293c5a4a3f4a7f (patch)
tree76545c3bde7aa617ae0c20f166a4bdb9fbab3c24 /dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild
parentdev-perl/File-ShareDir-Install: Bump to version 0.130.0 (diff)
downloadgentoo-b7f5f75ce9b6d9a867b0aae67f293c5a4a3f4a7f.tar.gz
gentoo-b7f5f75ce9b6d9a867b0aae67f293c5a4a3f4a7f.tar.bz2
gentoo-b7f5f75ce9b6d9a867b0aae67f293c5a4a3f4a7f.zip
dev-perl/File-ShareDir: Bump to version 1.116.0
- EAPI7 Upstream: - Use more recent File::ShareDir::Install - Fix errors in Windows style paths - Add support for externally setting overrides for the resolution path on a per-module/per-dist basis - Avoid bugs in _dist_file_new which continued to operate wrongly when _dist_dir_new returned 'undef' - Unify various @INC traversal code into a single function in order to make monkey-patching (for testing or whatever) the File::ShareDir subs easier - Remove unused/incomplete `_dist_packfile` function - Fix various test failures Keywording: - New dependency List-MoreUtils needs additional keywords, so keywords are temporarily dropped for: - riscv m68k-mint sparc64-solaris x64-solaris Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild')
-rw-r--r--dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild b/dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild
new file mode 100644
index 000000000000..584740d402f9
--- /dev/null
+++ b/dev-perl/File-ShareDir/File-ShareDir-1.116.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=1.116
+inherit perl-module
+
+DESCRIPTION="Locate per-dist and per-module shared files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/List-MoreUtils-0.428.0
+ >=dev-perl/Params-Util-1.70.0
+ )
+ virtual/perl-Carp
+ >=dev-perl/Class-Inspector-1.120.0
+ >=virtual/perl-File-Spec-0.800.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.130.0
+ test? (
+ >=virtual/perl-File-Path-2.80.0
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"