summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-07 21:18:18 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-07 21:20:15 +1200
commitafd2e3f7537d527d0b4027cdd03aefe74a5f5b40 (patch)
treeb99530f5b503a99ceb3e440a461520c8e2a5a9be /dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild
parentdev-python/nnpy: add py37/8/9 (diff)
downloadgentoo-afd2e3f7537d527d0b4027cdd03aefe74a5f5b40.tar.gz
gentoo-afd2e3f7537d527d0b4027cdd03aefe74a5f5b40.tar.bz2
gentoo-afd2e3f7537d527d0b4027cdd03aefe74a5f5b40.zip
dev-perl/File-Sync: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Remove unused/empty varialbe assignments - Parallel tests - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild')
-rw-r--r--dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild b/dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild
new file mode 100644
index 000000000000..d78dc62a634e
--- /dev/null
+++ b/dev-perl/File-Sync/File-Sync-0.110.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BRIANSKI
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Perl access to fsync() and sync() function calls"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}