summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-08 20:09:22 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-08 20:13:14 +1200
commit488b0725b1e3a5d63210139cd73da2e396e9949f (patch)
treedb518b0d0c6fedd8981508e6ac7e7a73faf5a49c /dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild
parentmedia-libs/libsdl2: removed obsolete 2.0.10-r1 (diff)
downloadgentoo-488b0725b1e3a5d63210139cd73da2e396e9949f.tar.gz
gentoo-488b0725b1e3a5d63210139cd73da2e396e9949f.tar.bz2
gentoo-488b0725b1e3a5d63210139cd73da2e396e9949f.zip
dev-perl/File-chmod: -r bump for EAPI7 + fixes
- EAPI7 - Parallel tests - Unconditionally remove unwanted tests Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild')
-rw-r--r--dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild b/dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild
new file mode 100644
index 000000000000..8aadb3947fdd
--- /dev/null
+++ b/dev-perl/File-chmod/File-chmod-0.420.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XENO
+DIST_VERSION=0.42
+inherit perl-module
+
+DESCRIPTION="Implements symbolic and ls chmod modes"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ virtual/perl-autodie
+ )
+"
+PERL_RM_FILES=(
+ t/author-critic.t
+ t/author-eol.t
+ t/release-cpan-changes.t
+ t/release-dist-manifest.t
+ t/release-meta-json.t
+ t/release-minimum-version.t
+ t/release-pod-coverage.t
+ t/release-pod-syntax.t
+ t/release-portability.t
+ t/release-test-version.t
+ t/release-unused-vars.t
+)