summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-08 21:48:41 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-08 21:48:41 +1200
commit3ed670575cbd0e321bb65aaf3a02df00a62291b6 (patch)
tree7e5be462af439543d4a4910dc2d7a874942d5399 /dev-perl/Filesys-Df
parentdev-perl/FileHandle-Unget: Bump to version 0.163.400 (diff)
downloadgentoo-3ed670575cbd0e321bb65aaf3a02df00a62291b6.tar.gz
gentoo-3ed670575cbd0e321bb65aaf3a02df00a62291b6.tar.bz2
gentoo-3ed670575cbd0e321bb65aaf3a02df00a62291b6.zip
dev-perl/Filesys-Df: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Enhance deps slightly - Remove unused/empty variable assignments - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Filesys-Df')
-rw-r--r--dev-perl/Filesys-Df/Filesys-Df-0.920.0-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Filesys-Df/Filesys-Df-0.920.0-r3.ebuild b/dev-perl/Filesys-Df/Filesys-Df-0.920.0-r3.ebuild
new file mode 100644
index 000000000000..6c4c62ab0d6f
--- /dev/null
+++ b/dev-perl/Filesys-Df/Filesys-Df-0.920.0-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=IGUTHRIE
+DIST_VERSION=0.92
+inherit perl-module
+
+DESCRIPTION="Disk free based on Filesys::Statvfs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}